Finally got Visual Studio 2017 Community Edition working again!

Finally got Visual Studio 2017 Community Edition working again!

OK – a technical post for any programmers out there whose system knowledge is a bit lacking these days (like mine, apparently). Basically, I had a problem and after a few months I now have an answer, so I am sharing.

The problem was that I had a working version of Visual Studio 2017 Community Edition and decided to upgrade. During the upgrade I got the following message:

PackageId:Microsoft.VisualStudio.MinShell.Interop.Msi;PackageAction:Install;ReturnCode:1911;

And the install failed. Worse still, I seemed unable to go back to my previous install. So I had no workign version of Visual Studio and even reinstalling failed.

I read the error log. It read:

Package ‘Microsoft.VisualStudio.MinShell.Interop.Msi,version=15.0.27102.0’ failed to install.
Search URL
https://aka.ms/VSSetupErrorReports?q=PackageId=Microsoft.VisualStudio.MinShell.Interop.Msi;PackageAction=Install;ReturnCode=1911
Details
MSI: C:\ProgramData\Microsoft\VisualStudio\Packages\Microsoft.VisualStudio.MinShell.Interop.Msi,version=15.0.27102.0\Microsoft.VisualStudio.MinShell.Interop.Msi.msi, Properties: REBOOT=ReallySuppress ARPSYSTEMCOMPONENT=1 MSIFASTINSTALL=”7″ VSEXTUI=”1″ 
Return code: 1603
Return code details: Fatal error during installation.
Message Id: 1911
Message Details: Could not register type library for file C:\Program Files (x86)\Common Files\Microsoft Shared\MSEnv\dte90.olb. Contact your support personnel.

So I subsequently tried everything, even posting in frustration on a number of technical help pages: Here is what I wrote on one:

But nothing worked.

So yesterday I did more searching and I found this post on Windows Installer itself not working. A poster called  suggested a solution to this apparently different question and a little light bulb went off in my head – could this be it? His solution:

Run system file checker (SFC) and see if it helps. Please follow these steps:

a. Press Windows + X keys and click Windows Powershell (admin).

b. Type the following command in command prompt and press Enter.

sfc /scannow

 

Turns out that the sfc is the system file checker and it verifies the integrity of every protected operating system file on your computer.

So I followed the instructions and voila!

Now I am not saying that this will work for everyone with this problem, but it certainly worked for me. :)

Greg

 

PS: the header picture is of my daughter in a recent dance competition.